Back to overview
Degraded
Server update
Feb 5, 2026 at 1:40pm UTC
Resolved
Feb 25, 2026 at 5:11am UTC
Legato server update completed
Affected services
Created
Feb 5, 2026 at 1:40pm UTC
Legato server is on update
Affected services